What's new

3d Pdf publishing problems


New Member

I have been trying to publish 3d pdf of an assembly with no luck. the error message reads "An internal exception occurred during publishing". We recently updated our software to v21 and we never had this problem with the older version. Anyone else having similar problems or a fix for this issue?

Swaroop3d pdf.JPG


New Member

Thank you, I tried it and I still keep getting the same error. But I found a workaround, I exported the assembly as a step file and opened the step file with Alibre and I was able to publish the 3d pdf from the step file. The colors in the pdf are all messed up, all my parts with special colors are set back to default but its better than not having a pdf.



Alibre Super User
Hi Swaroop,

Was this originally an imported file with subassemblies?
If yes, please check if there are actual 3D Parts in all Sub-assemblies. (Design Explorer)
If there are Sub-assemblies without 3D Parts, delete the "empty" subassembly.
F5 and save again, now try to create the 3D PDF again.

Sometimes there are also single corrupt faces/surfaces that cannot be output as 3D Parts/3D PDF Parts

It would also be helpful to send the Alibre file as a package file to the support team.
Last edited:


New Member
Hi Ralf,

No, the assembly was built from scratch and none of the sub-assemblies have any empty parts. I can generate pdfs from the individual parts and sub-assemblies but not the main assembly.