What's new

Assemblies inside assemblies

See the package please!! I was working on the thing and didn't realize that the constraints were hidden. So it let me build what i was trying to build but it was piling up a bunch of RED constraints. At one point it simply wouldn't let me do anything more!! So I just started deleting red constraints. It started falling apart soooo I save NOOOOO changes and started over! It kept on letting me build so I did!

The tractors/crawlers got stuck in, Then a bunch of stuff I mocked up like 1/2 inch impacts that I measured with some care at Harbor Freight Can't actually put belts in for the drive train!

What I'm asking for at this point is help with the constraints!!! The rotary table head and that part had no constraint issues when I stared adding the tractors. Then the sky started to fall!!

Thus far I'm just seeing if the parts will fit!! I've got some more actual design to do.
 

Attachments

  • first full mock up 3.AD_PKG
    1.7 MB · Views: 5
That video about sub assemblies helped!! Thanks for taking time to produce them!!!
Something I failed to mention was that when I went to "save" It wouldn't let me save. Saying the sprockets I imported were "copies"!! It said it took away the option to save because of that! It has fought me several times in the sense I find it hard to import the parts. Which I used to do regularly!!

Got any advice on importing step files and getting them into the appropriate "insert design" folder I have found it nearly impossible getting the step file into my "insert design" relative to the assembly I'm working on!!!

Also what is the purpose of the mostly black page that pops up when I go to save a piece of work. I mostly ignore it
I don't understand it's purpose other than to clutter things up!! It is the one that offers; description, core properties, version comment etc.
 

Ken226

Senior Member
I downloaded your package file and checked it out. Here's a video of what I found:


Harold,

I have subassemblies that have moving parts and gear constraints When I import the subassembly into a larger assembly, the subassembly gear constraints and moving parts appear to have lost their freedoms of motion.

I've been skipping the subassemblies and assembling those devices inside the main assembly so they retain their freedoms of motion.

Am I doing something wrong.
 
you mentioned that the assy. was missing timing belts; Do you know how to "import them" so that at least they appear to be there!! OR is there a way to "import chains and sprockets" so at least they make an appearance??
 

HaroldL

Alibre Super User
I have subassemblies that have moving parts and gear constraints When I import the subassembly into a larger assembly, the subassembly gear constraints and moving parts appear to have lost their freedoms of motion.
Right click on the sub assembly in the Design Explorer and select "Make Flexible". Be aware though, I think that only works for one level down.
 

Ken226

Senior Member
Right click on the sub assembly in the Design Explorer and select "Make Flexible". Be aware though, I think that only works for one level down.

Worked perfectly. Thank you.


you mentioned that the assy. was missing timing belts; Do you know how to "import them" so that at least they appear to be there!! OR is there a way to "import chains and sprockets" so at least they make an appearance??

I modeled chains, but they are just cosmetic. I could model and constrain a chain assembly, but would have no idea how to constrain the links to the sprocket teeth in a way that would allow it to work.

Timing chains.jpg
 
I do have a screenshot that it just showed me. IT WOULD NOT LET ME SAVE THE DRAWING AFTER WORKING AND BUILDING FROM SCRATCH THE WHOLE SUB ASSEMBLY!!! Please find the attached screen shots!!

It would NOT allow me to send a package file!!! though I think you can see that it drew up flawlessly.. Nothing showed any error till i went to save!!! It just occurred to me Is McMaster-Carr website having a tizzy fit??
 

Attachments

  • tractor assy. save pic.PNG
    tractor assy. save pic.PNG
    301.7 KB · Views: 18
  • tractor assy. save 2 pic.PNG
    tractor assy. save 2 pic.PNG
    304 KB · Views: 18

HaroldL

Alibre Super User
have no idea how to constrain the links to the sprocket teeth in a way that would allow it to work.
Alibre does not have a constraint mechanism that allows a chain to actually rotate and translate in path like a real chain and sprocket.
I'm not sure when SolidWorks added it but here's a video showing how a dynamic chain is assembled. Dream on.
 

HaroldL

Alibre Super User
I do have a screenshot that it just showed me. IT WOULD NOT LET ME SAVE THE DRAWING AFTER WORKING AND BUILDING FROM SCRATCH THE WHOLE SUB ASSEMBLY!!! Please find the attached screen shots!!

It would NOT allow me to send a package file!!! though I think you can see that it drew up flawlessly.. Nothing showed any error till i went to save!!! It just occurred to me Is McMaster-Carr website having a tizzy fit??
How did you put your assembly together that it created all "new" parts? I don't think I've ever seen a situation like this.
Can you describe the steps you took when you created the assembly model?

I don't know that McMaster-Carr's web site would have anything to do with how your model is created. What's the issue you're seeing with it?

Got any advice on importing step files and getting them into the appropriate "insert design" folder I have found it nearly impossible getting the step file into my "insert design" relative to the assembly I'm working on!!!
When I download any parts from McMaster-Carr or Trace Parts they are put into my Downloads folder. I have a setting that will open STEP files in Alibre as soon as they are downloaded. When they open in AD I immediately SAVE and choose the directory I want them in. Sometimes its my project folder and sometimes it's different, like hardware, nuts, bolts, screws, which I have their own folders for. Once the part is saved I will close the file then, in the assembly, select Insert Design and navigate to the folder I saved the file to.

IF the part does not open in AD I navigate to the Downloads folder, find the part and move it to the folder I want it in. It is then available to insert in the assembly model via Insert Design.
 

DavidJ

Alibre Super User
Staff member
Try inserting the part ONCE, thereafter use 'Insert Duplicate' (from right click menu) - either that or when you first insert the import part insert as many instances as you need.

If you import the part separately from STEP on several occasions, AD will make a part file for each import, so you get duplicate files.

You only need to import the file once. There after you can use multiple instances of it.
 
Top