What's new

Downloaded MeshCAM v9 from Alibre runs extremely slow

Just purchased MeshCAMv9 from Aibre to go with my Alibre Design expert and it runs extremely slow if at all. Alibre was no help, said to contact MeshCAM which I did. They tried to be helpful but no luck. Tried uninstall/reinstall same thing. Did uninstall and reinstalled software from MechCAM website no change. Automatically loaded my Alibre MeshCAM license so I wonder if the LIcense from Alibre is the problem. Alibre Design on the same computer runs just fine. I am running windows 10 with all updates. Machine was just cleaned and tuned up so runs very well. Internal graphics card but is fine with Alibre. 1TB SSD, 8GB RAM


Staff member
I run MeshCAM without any obvious performance problems. Lots of customers have purchased MeshCAM via Alibre, I'm not aware of other reports like yours, so if there have been some there aren't many.

Does 'slow' relate to MeshCAM before you've loaded a file, or only after loading a file? If so, how big is the file used? Does it work OK with the sample files provided with MeshCAM. Did you ask MeshCAM about your system spec? 8GB memory isn't a lot especially if it's being shared by the graphics adapter (what pixel count is screen, do you have more than one monitor). That may or may not turn out to be a factor - it's just a thought.

Alibre can only be of limited help as we don't produce MeshCAM.
Slow means it takes 30 seconds or more to load, and when it does it seems to be loading multiple versions as the screen flickers and an occasional ”not responding” message occurs. Finally the welcome splash screen. But still not info on the left side main menu area. May finally load a file but after that it’s useless. I did download a trial version in December, never had time to evaluate it, but it did seem to function fine. I would think Alibre Design Expert is much more graphics intensive but it runs fine. I even uninstalled MeshCAM, turned off the computer, started the computer again, downloaded the MeshCAM file directly from GRZ but when I went to open it it had already been registered under my Alibre license. My intent was to get a trial license to see if it would function properly but I can’t even do that.


Staff member
I wonder if there is some other app on the computer that conflicts with MeshCAM, or if there is a damaged Windows component or similar that MeshCAM relies upon. . Licences tend to either work or not work rather than slow things down.

If you have another computer you could try MeshCAM on I'd suggest you do that.

MeshCAM opens almost instantly from a desktop shortcut for me.


Alibre Super User
@custommetal , if you have anti-virus, windows defender or windows search turned on, you may want to turn those off and test the start up time again. I've had many problems in the past related to virus checking software that likes to scan things when files are accessed or applications are first started. May not be the case for you, but just another thing to rule in/out!

As @DavidJ says, RAM may be an issue. Open task manager and see how much disc activity there is when you open MeshCAM, if there is not enough RAM, Windows will us the swap file on disc instead of RAM .... and that is really slow. Another issue I had until I expanded from 8GB to 32GB RAM.
DavidJ…..I do have an older computer so will try it on that one. Just doesn’t make sense why AD expert runs fine and MeshCAM just won’t.

Simonb65….I will use your suggestion and check out the task manager and windows defender.