What's new

Inventor Import - Section Not working

Hi all,

I had an inventor part which I imported and knocked up a quick drawing. I did a section through the holes in it but then in the section view it didn't show the holes?
Has anyone else seen this behaviour?



Alibre Super User
Staff member
Most likely a bad import. Did you use Check Part when importing? Have you tried different import settings? In most cases (but not 100%) it's possible to find import settings that will work well.

Failure of Precise Section View (in 3D workspace) is an indication of import that isn't quite right, even though other operations may seem to work.

Not clear if your issue is in 3D or 2D...
I'll try a check on import, problem is 2d, creating a drawing of the 3d part.
Pretty new to Alibre so finding my feet a little.
Just tried with healing, check part etc on import and this is the drawing view. Also attached the part


  • Untitled.png
    16 KB · Views: 12
    169.5 KB · Views: 11


Alibre Super User
Staff member
Something a bit odd about that part (or the import process). Precise section on YZ plane doesn't work in 3D or parallel to it, Yet does work in XY plane.

Problem is not user error.
Yeah not sure? I've had the 3d section not work on certain stp imports. But I got given this to remodel in NX 12. Can't bring inventor into nx12, so did it in Alibre and did a quick drawing to get the dims off it.

When you have do a 2d section on a drawing, then change the view display in the section the hidden lines of all the holes show up, so it's like it's not being "cut" so to speak.


Alibre Super User
Staff member
Yeah, saw that hidden lines work OK.

Do you know which version of Inventor it was saved from? Just wondering if there has been an Inventor update that our import module doesn't handle yet....

At least hidden lines gives a way to progress...
Hi, sorry I don't know. I'll check round online to see if there's a way to find out. Someone made a little Catia checker there may be a inventor one as well. I'll report back:)


Alibre Super User
I've played around a little bit...

I've imported it with no face processing chosen and override to centimeter, only for completeness...
Then i moved the "top"-face slightly down...and as can be see, the cut works in the drawing...



Alibre Super User
Another option/workaround:

- Import the TESTER SECTION.ipt and save,
- Export as STEP AP 242 and save,
- Create a 2D Drawing with section views,



Alibre Super User
I just imported the model with these settings:


I then created a Precise Section View and it failed, Then I followed your example and moved the top face down only .001 mm and the section view worked. That's odd but maybe something to remember for other imported models that don't section. It would be interesting to know why moving a face would allow the section view to work. :confused: :confused: