What's new

V25 External thread problem

Adi

Member
Hello!
When I tries to make external metric thread, I have a problem with representation of the thread. For eg.- this is an model with m8 thread, but, despite that grapihics of thread looks fine- it is on 8mm diameter cylinder, representation of the tread is very small (here 0,644mm, and can't be changed). Additionaly, when I want to prepare 2D drawing, the thread representation is also so small.. It is a bug, or I am making something wrong?
 

Attachments

  • alibre 1.png
    alibre 1.png
    77.2 KB · Views: 31

Ken226

Alibre Super User
Try clicking the checkbox for "filter by selected geometry". Since I created an 8mm diameter cylinder as the thread source, I selected "major". It appears to work.

1663023960676.png

1663023838592.png


If that doesn't work, upload your part file and we can take a look at it.
 

Attachments

  • 1663023811371.png
    1663023811371.png
    340.8 KB · Views: 10
Last edited:

Adi

Member
Thank You for reply.
I found out, when this problem occurs- only when I import a geometry from step file.
Problem occurs even, when STEP file was created in Alibre Design.
File which I attached is a simple cylinder, exported to STEP file, and imported back again ( I found the problem while I was opening step file created (probably) in Fusin 360)

I'm not sure if this is connected with strange import of some STEP files- cylindrical object (shafts, holes) imports as it will be virtually cut in same point- for EG there is edge on side survace of cylinders, or circle is imported in way, which program reads it as radius, not circle (when makind 2d drawing from model which was imported from STEP)
 

Attachments

  • thread issue.AD_PRT
    249.5 KB · Views: 8

HaroldL

Alibre Super User
Yeah, there is a problem with this part. When I select Filter by Selected Geometry it switches to M64.o_O

1663181322319.png

So I deleted the feature and reapplied it. Then this what I've never seen this before. When I select Filter by Selected Geometry before selecting an edge I get this pop up.:oops:

1663181440473.png
 
Last edited:

idslk

Alibre Super User
@Adi,

have you changed/overwritten the untits during importing the Step-file?
Could you Post the original Step-filoe as well?
It looks like a centimeter <-> millimeter issue...

Regards
Stefan
 

Adi

Member
I don't have that window, but, depending on which type of thread I chose (ISO fine, ISO corsae) I can see M68 or M61 o_O

I also think that there is some problem with units. I use only mm, and this step file was also made in mm. I forced program to import file as mm, and the result is the same.
 

Attachments

  • Nowa Część (1).stp
    8.1 KB · Views: 6

idslk

Alibre Super User
Interesting, i've created an 8mm cylinder newly in AlibreDesign, put an M8 thread on it and every thing is fine...
After this a made a similar cylinder without thread and exported it as step AP209.
Then i've opened this STP-file with Alibre and magically it has the same behaviour as the threadstarter file - it would make an M68 thread.

1663187696090.png

Regards
Stefan
 

HaroldL

Alibre Super User
It looks like that window is a normal consequence of selecting "Filter by Selected Geometry" without having selected an edge.


I just downloaded and imported the model. Here are the results of the check part analysis.

import advisor.jpg

check part.jpg

Healing Analysis.jpg

Looks to be a good file without any errors.
 
Last edited:

DavidJ

Alibre Super User
Staff member
I tried a simple 8mm cylinder, 50mm long. Exported to STEP AP203 (with 'model units' for export) - re-imported (without units override) - model showed with cm units.

Applying M8 cosmetic thread worked fine. Repeated after switching display units to mm, again worked fine.

Maybe check STEP export units? You should not routinely need to set units during import - that is an override, for when the model has units incorrectly coded (it will change the size). Change display units after import if you wish to work in alternate units.

I do recall a previous issue with imported STEP files when inserted into assemblies - that was resolved, but this feels very much like it..... I suspect there is some extra detail still to be revealed.
 

Adi

Member
Hmm,
Step export units are in mm also.
I made some more tests (every step file was an export from Alibre):
1) STEP 203 import, and thread is wrong (M68, not M8, or M8 thread is shown as at picture at first post- it wont be a problem if it will apper as normal lines in 2D drawing module, but also the same dimensions are in 2D, so You have to drawn thread lines mannualy..)

2) Step 214- the same as above
3) Step 242- I can't do thread, as the cirlce at the end of the cylinder... is not a circle- program read this as 2 separate curves.

Then I tried to make a 2d drawing from that parts imported from steps:
1)STEP 203 and 214 shows circles as circles, but on one projection there is a nasty solid line, which is imposible to remove (or I don't known how to do- maybe someone have any idea?)
2) Step 242- circles arre treat as 2 curves, and that nasty lines appers on 2 projections, as at attached screens

I wonder if Alibre Team read these topics and could ask programers to make a patch for this issue? We can see that I am not only person with this problem.
 

Attachments

  • 203 or 214.PNG
    203 or 214.PNG
    5.5 KB · Views: 7
  • 242.PNG
    242.PNG
    5.3 KB · Views: 7

DavidJ

Alibre Super User
Staff member
Adi, your latest results contradict mine. What import settings did you use? (All of the settings). Something must be different or we would get same outcome. I did notice the 2 edge issue with AP242, have mentioned to the Product Manager to take a look.
 

Adi

Member
Adi, your latest results contradict mine. What import settings did you use? (All of the settings). Something must be different or we would get same outcome. I did notice the 2 edge issue with AP242, have mentioned to the Product Manager to take a look.
Just standard one- only cheked thing is "show options during import" ;) and in the first postion is something which probably should be translated as "solid stich", but in this simple case I can see only one dfference- when I choose something with could be translated as "do not stitch" the tool to threads don't work at all- windows open, but program do not accept any cylinder edges.
 

Attachments

  • import.png
    import.png
    18.6 KB · Views: 6

DavidJ

Alibre Super User
Staff member
Very odd - I'm still not getting the problem if I try Stefan's import settings.

Stefan - your two external thread dialogue images at end of post #13 show different values for minor diameter of thread, when 'filter by selected geomtery' is selected or not - yet I get same (expected) value either way. Did some particular workflow give the very small minor diameter?
 

idslk

Alibre Super User
Did some particular workflow give the very small minor diameter?
Hello David,

done nothing unusual as written before...
I also have tried an different CAD to provide the STP-file. Imported it into Albre as discribed and it ends up in something odd in regards to the External Thread Tool as with the alibre made STP-File. While the grafical cylinder representation show a diameter of 8mm the Tool thinks it is 10 times smaller...
I have no idea...

Regards
Stefan
 

DavidJ

Alibre Super User
Staff member
Really odd. If I open the OP's STEP file, the external thread tool offers M68 thread.

If I create an 8mm cylinder, export to STEP and re-import, external thread tool offers M8 thread (as you would hope).

What happens for you with my exported STEP file??
 

Attachments

  • 8mm cylinder(203).stp
    7.4 KB · Views: 5

Adi

Member
DavidJ, adding thread to your step file works fine, but when I made 2d drawing, I still have that nasty line on one of projection.
 

DavidJ

Alibre Super User
Staff member
Adi,

I can reproduce the line in one view - I think that is related to a way the projections are produced. Even in my original AD_PRT a drawing of cylinder shows projected Diameter in 3 derived views, but pairs of Radii in the 4th view - though no line along centre. The export/re-import for some reason results in a line being added in that derived view in drawing. You can at least send that extra line to an invisible layer

I can't yet reproduce from scratch the odd behaviour of the external thread tool, which makes me wonder what is different about your export/import process, or your system compared to mine. If I can identify the key thing, and hence give a reproducible way to trigger the issue, it makes things much simpler for Development.
 

DavidJ

Alibre Super User
Staff member
OK - I've managed to re-produce the threading issue. And I have a possible theory about why this might be happening.

The short-term fix is only to export to STEP in Model units. Hopefully longer term the external thread tool can be made more robust.

I'll discuss with Product Manager how to prioritise the 2 separate issues.
 
Top