What's new

v25 is now live - June 20, 2022

DavidJ

Alibre Super User
Staff member
And standard options (v24)

GridKey.jpg

Looks like a duplicated setting has crept in.
 

idslk

Alibre Super User
Looks like a duplicated setting has crept in.
That's what i found too :)

"quick fix":
Goto System Options/KeyboardShortcuts and then:

If you change the first occurence of the keyboard shortcut for Global Parameters:
1654175514991.png

click into field:
1654175596441.png

change shortcut for example to:
1654175669192.png

accept with OK-Button

Your shortcut to the Grid (CTRL-Shift-G) should now work as described in the HELP. (You also have a newly defined shortcut to GP) (as long as you don't reset the shortcuts to default...)

Regards
Stefan
 

simonb65

Alibre Super User
@Max, Would have been nice to also have the show/hide icon along side parts and assemblies as they are the first things that I hide when trying to declutter the model ...

1655768446415.png
 

HaroldL

Alibre Super User
I got this message from Trend Micro when updating to Alibre v25:
1655826293329.png

This is new, at least to me. What is TestWriteAccess.exe?

And then I get this:
1655826602213.png
 

pridbor

Senior Member
I know it's not an important item, but the Home page still says "Beta" in 2 places.

Sorry, I fell into the trap of launching the old version :) I just found out about the multiple versions.



Preben
 
Last edited:

Ex Machina

Member
Hello everyone, first post in these forums here.

I have been using v24 for a few months now and just updated to v25. I am on a laptop with an iGPU (AMD Radeon) and a discrete GPU (RTX3060). I have selected the RTX in the system options, I went to the Graphics display in the Windows setting and set Alibre Design to "High Performance", but the software still uses the iGPU and the performance is annoyingly lower. v24 worked perfectly up till today when I updated.

Am I doing something wrong? Do I need to check another option somewhere?
1655888049283.png
1655888229732.png
 
Last edited:

Ex Machina

Member
I did all that and it wasn't working. And then I thought about it...

I reinstalled v25, didn't do the graphics display setting and:

1) In the software's System Options it says it's using the AMD Radeon iGPU
2) The performance is great and when I use the software the Task Manager reports that the discrete GPU is being used. And so does the ASUS utility.
1655892019748.png
1655892026723.png

Could this be a bug, possibly?

P.S. This is a laptop with no mux switch for the GPUs...
 

DavidJ

Alibre Super User
Staff member
In modern dual GPU laptops, the integrated GPU is always connected to the screen - in 'high performance' mode it acts rather like a frame buffer between the discrete GPU and the screen.

Now that doesn't give a direct answer - but the 'switch' in system options pre-dates the arrangements for recent laptops.
 

Ex Machina

Member
OK, fair enough. It's just that in v24, I'm pretty sure it worked as intended... Anyways, thanks for the quick responses.
 

simonb65

Alibre Super User
I have been using v24 for a few months now and just updated to v25. I am on a laptop with an iGPU (AMD Radeon) and a discrete GPU (RTX3060). I have selected the RTX in the system options, I went to the Graphics display in the Windows setting and set Alibre Design to "High Performance", but the software still uses the iGPU and the performance is annoyingly lower. v24 worked perfectly up till today when I updated.

Am I doing something wrong? Do I need to check another option somewhere?
1655888049283.png
Also remember that v25 is installed in a different location (it's own directory). So the file that the performance is set to points towards the old v24 .exe in the Alibre design directory! You need to add the new v25 .exe which is somewhere else. The performance applications only point to specific .exe's. Click on the Alibre Design above and check where the file path is pointing to, I think you'll find it's not the v25 .exe as you (and many others) may be assuming!

Not sure is Alibre have considered this negative side effect of having side-by-side installs! @Max, can you confirm if this has been considered.
 

NateLiqGrav

Alibre Super User
I thought about this a while back: It might be beneficial to create a loader program called Alibre.exe that sits at a constant location and when executed passes all called parameters to the correct version .exe (located based on a setting stored in the registry). An additional (separate .exe) version selection utility program could be created to keep track of what versions are installed, change the registry per user selection, or uninstall a version.
 

simonb65

Alibre Super User
I thought about this a while back: It might be beneficial to create a loader program called Alibre.exe that sits at a constant location and when executed passes all called parameters to the correct version .exe (located based on a setting stored in the registry). An additional (separate .exe) version selection utility program could be created to keep track of what versions are installed, change the registry per user selection, or uninstall a version.
+1, great solution Nate.
 

HaroldL

Alibre Super User
Good idea Nate. That would fix the issue that now when I download a part/file and select Open with in the download dialog I need to navigate out to the correct version of Alibre to open it with. Just another quirk that goes with allowing multiple versions to be installed I guess.
 
Top