What's new

3D PARSING ERROR with Print 3D pdf

wsimonton

Senior Member
I obtained a strange result tonight. I printed a 3D pdf of Climax 1551 and at the end of the process a "3D Parsing Error" was reported. A 2D pdf appeared in Adobe Reader without apparent errors. If one clicked on the drawing to "activate" a Picasso locomotive appeared. See below.

Opening the file in Adobe Acrobat 9.0 also resulted in the Picasso locomotive. Until today I have not had problems with print to 3D pdf. Suggestions?

I exited Alibre, reloaded the Climax and attempted to print again. No error message but same result.

Up until these attempts I have not had any problems producing a 3D pdf . Thoughts?
3D Parsing Error with Print 3D pdf.jpg
 

DavidJ

Alibre Super User
Staff member
Try using legacy display mode when generating the PDF, see if result is any better.
 

wsimonton

Senior Member
I first attempted 3D printing just the Engine without running gear in legacy mode. When it finished it popped up in Adobe Reader and reported a "3D Parsing Error" and 3D mode would not activate.

I then opened the 3D drawing in Adobe Acrobat and it crashed immediately.

I re-opened the 3D drawing in Adobe Acrobat and successfully opened it in 3D mode.

I then attempted to 3D print the complete locomotive. It again reported a "3D Parsing Error" and I did not attempt to open 3D mode in Reader.

I did attempt to open in Adobe Acrobat and was on opening confronted with a 2D drawing in the same Picasso appearance as illustrated in the above jpg. I did open it in 3D mode with the following result.
 

Attachments

  • ScreenShot036.jpg
    ScreenShot036.jpg
    144.1 KB · Views: 45

NateLiqGrav

Alibre Super User
IDK how to fix this. Just wanted to say that's a beautiful model (other than the obvious conversion flaws)
 

wsimonton

Senior Member
I have finally resolved the 3D pdf printing issues which first arose a year ago - sort of. Its works without using a small number of parts in the native Alibre format.

a) The printing with "fractal" images which were generated during the "printing" process were resolved by Exporting a limited number of parts which contained Lofts as Step Files (.stp) to create a solid body and then Re-imported in Alibre and substituting those (new name to differentiate) for the native Alibre parts in the Assembly.

b) Also attempts to open the 3D pdf in Adobe Acrobat and Acrobat Reader generated a "Parsing Error" and the 3D pdf would usually not display. During loading of the Assembly in Alibre an Error Message would appear stating Alibre could not find "something". I say something because it was not a part but a reference which appeared to refer to a Part but without a ".AD_PRT" identifier - "1-2inx3in Hex Bolt" -- not "1-2x3in Hex Bolt.AD_PRT"

I finally tracked the error message down to an Assembly with a few parts. Checked out each part without generating any Error Message. Started re-assembling the Assembly from scratch and saved the new Assembly with the old name. That worked as the Error Message was no longer generated. The Error was in the Assembly File - not in any of the parts which comprised the Assembly.

The 3D pdf may be found at: https://s3.amazonaws.com/SIMONTON/1551.pdf

A very large pdf file (132.1MB) which clearly illustrates a 70 Ton 1919 Climax Mfg. Co. Geared Steam Locomotive. A work in progress with about 10,000 parts. Best viewed in Daylight and Solid Outline in Adobe Acrobat or Acrobat Reader. If any "fractals" remain let me know a some Alibre parts containing Lofts remain.
 

tgarson

Member
Thank you for your post(s). They led me to a solution to a similar problem I was having: That of producing a usable 3D PDF from Alibres "Publish to 3D PDF" feature.

With a very complex assembly, I was getting 3D files with severe "fractalizing" to paraphrase your term. Once you showed that it was possible to not have this happen, I went on a hunt for the culprit. It turned out that these difficulties were caused by having PDF Creator and PDF Architect installed on the system. They had been there for some time with no previous hint of causing dysfunction as they had worked well for creating, editing and viewing 2D PDFs originating from other applications.

After removing both PDF Creator and PDF Architect from my system, Alibre was able to generate a "clean" 3D PDF which views as it should in Acrobat DC reader.

3/29/21:
Just discovered that since I removed DPF Creator to get Publish to 3D PDF to work properly, I can no longer create 2D PDFs from drawings..... Alibre technical, please help resolve this.
 
Last edited:

wsimonton

Senior Member
Alibre Support is working on a Solution/Suggestion for dealing with Restraints which refer to Deleted or Replaced Parts and result in an Error Message.

Support is also working on a Assembly of mine which will not Publish to 3D pdf (just hangs). Hope both those are resolved shortly although the Export/Import to create a Solid is sometimes still required to eliminate "Fractals" in a Publish to 3D pdf.
 

HaroldL

Alibre Super User
A very large pdf file (132.1MB) which clearly illustrates a 70 Ton 1919 Climax Mfg. Co. Geared Steam Locomotive. A work in progress with about 10,000 parts.
That's pretty amazing. How much do you have left to do for the model to be complete? What are your computer specs to handle a model with that size file?
 

wsimonton

Senior Member
I have all the basic Climax parts done with few exceptions which due to lack of access to the locomotive or lack of access to the parts as they are now concealed due to construction. I need to go back a clean up a few parts which were done when I was just learning Alibre and trying to stay ahead of the reconstruction (although I have worked in 2D CADD since 1980). Unfortunately the railroad's new lessee took over finishing the locomotive and my access has been and is very limited. It's now running under steam and to climb all over its to get details, I have to go with permission out of season when the locomotive is cold. Most of the parts left do do are in the boiler (the backhead and tube sheet stays (about 36) are unique due to geometry although mirroring will reduce the work and parts which I was unable to measure and document before the end of 2015 when the lessee took over. Only about 500 hundred difficult parts to go (difficult to do in Alibre or difficult to document).

I anticipate starting work on a 15 Ton Class A Climax which is just beginning to be restored to operating condition later this year.

Alibre Design™ Expert
Version: V22 64-bit [Build 22053]
HP Model H8-1230t
Microsoft Windows NT 10.0.17134.0
Processor Information: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Number of Processors: 8
Memory 16GB
Hard Drive 1 TB SSD with 3 other backup and storage drives
 
Last edited:

wsimonton

Senior Member
I have continued to "run into" parts which exhibit a "Fractal" appearance from time to time and MAY cause a parsing error when Publishing to a 3D pdf. I have found a number of occasions where exporting and importing a a solid part "cured" the issue. However on a couple of other occasions that failed.

I think I have solved one part of the problem (not solved just found a work around). The issue appears to occur if one uses a LOFT in creating the Part and the MIRRORS the LOFT in creating the Part. Some of the Parts I exported and reimported had the same construction. By redoing the LOFT(s) without MIRRORING the problem/issue was resolved in a number of cases.

Why this works I do not know as it's above my pay scale and expertise.

Hope this work around helps someone else.

I have attached the original file and the modified file as an illustration. The Original file "fractals" even if published alone on MY system.
 

Attachments

  • Brake Rod Split - Original.AD_PKG
    831.2 KB · Views: 0
  • Brake Rod Split - Modified.AD_PKG
    213.9 KB · Views: 1
Last edited:
Top